angular8 の旧ブラウザ対応(IE11, android標準ブラウザ)

五月雨にて失礼いたします。

angular8 で作成したプロジェクトをIE11, android4.4 で確認したところ、polyfill.jsでエラーが発生し、遅延モジュールが読み込まれませんでした。

対処方法について調査したところ、pollyfill.ts に core-js をインポートする記述を追記することで正常に表示されました。

import 'core-js';

そこで質問なのですがangular公式のブラウザサポートには上記ブラウザも対応しており、
「angularプロジェクトで旧ブラウザを対応するには、後から設定を追記する必要がある(デフォルトではサポートしない)」という認識で正しいでしょうか?

Angular 8
TypeScript 3.5.3

Angular CLIで生成したプロジェクトの初期状態ではIE11などでは動作しないで真っ白な画面になってた気がします。

サポートするブラウザにあわせて、polyfills.tsファイルのコメントアウトされている箇所を変更して、polyfillを有効にするようになっています。

https://angular.io/guide/browser-support

1 Like