ng e2eコマンド実行時のエラーを解消したい

事象

e2eテストを実行するために、「ng e2e」コマンドを実行した結果、以下のようなエラーが発生しています。
[22:26:40] E/launcher - session not created: Chrome version must be between 71 and 75
  (Driver info: chromedriver=2.46.628402 (536cd7adbad73a3783fdc2cab92ab2ba7ec361e1),platform=Windows NT 10.0.18362 x86_64)
[22:26:40] E/launcher - SessionNotCreatedError: session not created: Chrome version must be between 71 and 75
  (Driver info: chromedriver=2.46.628402 (536cd7adbad73a3783fdc2cab92ab2ba7ec361e1),platform=Windows NT 10.0.18362 x86_64)

内容を見るに、chromedriverのバージョンが古く、PCにインストールされているChromeのバージョンに対応していないことが原因と思っています。

Angular公式ガイドを見ると、「ng e2e」コマンド実行時にはデフォルトで「–webdriverUpdate=true」のオプションが適用されるとあるため、driverは自動的にアップデートされるものと思っていましたが、なぜupdateされないのかが分からず困っています。
https://angular.jp/cli/e2e

質問事項

  1. エラーを解決するためにはどうするべきか。
  2. テストコマンド実行時にdriverがアップデートされないのはなぜか。

環境情報等

Chrome:81.0.4044.113(2020/04/20時点最新バージョン)
package.json(抜粋)

"dependencies": {
  "@angular/animations": "^8.1.3",
  "@angular/cdk": "^8.2.0",
  "@angular/common": "^8.1.3",
  "@angular/compiler": "^8.1.3",
  "@angular/core": "^8.1.3",
  "@angular/forms": "^8.1.3",
  "@angular/material": "^8.2.0",
  "@angular/platform-browser": "^8.1.3",
  "@angular/platform-browser-dynamic": "^8.1.3",
  "@angular/router": "^8.1.3",
  "@angular/upgrade": "^8.1.3",
  "base64url": "^3.0.1",
  "classlist.js": "^1.1.20150312",
  "core-js": "^2.5.4",
  "element-closest-polyfill": "^1.0.0",
  "rxjs": "^6.3.0",
  "url-search-params-polyfill": "^7.0.0",
  "web-animations-js": "^2.3.2",
  "zone.js": "~0.9.1"
},
"devDependencies": {
  "@angular-devkit/build-angular": "~0.801.3",
  "@angular-devkit/build-ng-packagr": "~0.801.3",
  "@angular/cli": "^8.1.3",
  "@angular/compiler-cli": "^8.1.3",
  "@angular/platform-server": "^8.1.3",
  "@types/jasmine": "~2.8.8",
  "@types/jasminewd2": "^2.0.4",
  "@types/node": "~8.9.4",
  "codelyzer": "^5.0.1",
  "eslint": "^6.5.1",
  "htmlhint": "^0.11.0",
  "cloc": "^2.5.0",
  "husky": "^1.3.1",
  "jasmine-core": "~2.99.1",
  "jasmine-spec-reporter": "~4.2.1",
  "karma": "~3.0.0",
  "karma-chrome-launcher": "~2.2.0",
  "karma-coverage-istanbul-reporter": "~2.0.1",
  "karma-jasmine": "~1.1.2",
  "karma-jasmine-html-reporter": "^0.2.2",
  "karma-junit-reporter": "~1.2.0",
  "karma-spec-reporter": "~0.0.32",
  "lint-staged": "^8.1.4",
  "lodash": "^4.16.2",
  "ng-packagr": "^5.1.0",
  "prettier": "1.16.4",
  "protractor": "~5.4.0",
  "stylelint": "^11.0.0",
  "stylelint-config-recommended": "^3.0.0",
  "ts-node": "~7.0.0",
  "tsickle": "^0.35.0",
  "tslib": "^1.9.0",
  "tslint": "^5.0.0",
  "tslint-config-prettier": "^1.18.0",
  "tslint-plugin-prettier": "^2.0.1",
  "typescript": "~3.4.5"
}

Updating Protractor’s webdriver-managerであれば、こちらに issue ありますね


参考になれば幸いです。

@masashiyoshiwara

エラーを解決するためにはどうするべきか。

記載いただいてるエラーを手元で再現できなかったので、あくまでアイデアですが2つ思いつきました。

  • node_modules ディレクトリを削除して再度ライブラリをインストールする
  • 手動でアップデートする node node_modules/protractor/bin/webdriver-manager update

ご回答ありがとうございます。
明確な理由は不明ですが、手動アップデートにてエラーが解決致しました。